Map getting screwed up

Need help getting the classic version of the ninja game to work? Ask here. Find a bug? Tell us here.
The Loneliest Number
Posts: 1
Joined: 2009.08.11 (18:25)

Postby MistaX8 » 2009.08.11 (18:40)

Hello.

It's been quite some time since I've played this game, and I just started messing around with it again recently, in particular, NED.

I've had a bit of trouble with saving maps before, but I figured out all the stuff I was doing wrong, and I got a few maps to work correctly.

They're not that great, but if you want to see them:

http://www.nmaps.net/browse?q=author:MistaX8

But I made all those maps a while ago. In the last two days, I've been trying to make a map, but it will not save correctly. I make the whole map, I test everything to make sure it works, everything works fine. I make sure all the objects are reset. I make sure I hit pgdn to save the map data to the text box. I copy the textbox exactly as is, I put it in the userlevels.txt file, and I go to play it in the user levels, and all the tiles are messed up. Some of them get switched around (stuff that was on the top of the screen now on the bottom) and some of them just look like a chunk of a different level. Most of the objects, however, stay where they are.

I can't figure out what I'm doing wrong, I made sure I formatted the map properly in the userlevels.txt file (and I didn't forget the # on the end either). Everything else checks out ok. Before I leave the map editor, everything looks and works fine. I don't understand what's happening between there and when I save it in the .sol file. Has anyone had this problem before? And if so, what was wrong that was doing it?

EDIT: Well, I still don't know what was actually wrong, but I deleted the game and re-downloaded it and now everything seems to be working fine.

Return to “Troubleshooting (Nv1.4)”

Who is online

Users browsing this forum: Google [Bot] and 1 guest